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Preface

Presto! ImageFolio is a professional multimedia image processing soft-
ware package which is easy to learn. This manual, along with the online
help available in the software, give you all the necessary information
needed to use the software and understand its features.

The manual is organized as follows:

Briefly introduces the functions and features included in the software,
and lists the system requirements to install the program.

Provides instructions for backup and installation of the program.

Provides Instructions to start running the software, explains key-
board/mouse commands and describes each part of the Presto! ImageFo-
lio screens.

Explains how files are managed.

Explains how to edit or create images and the tools provided to do so.



Explains the function of each command under the Edit menu, such as Cut,
Copy, Paste, Crop, etc.

Describes some of the basic image processing functions and commands
under the Transform menu such as for rotating, inverting and converting
images.

Explains the features which enable you to creatively improve images by
adjusting Brightness and Contrast, Hue and Saturation, using the Mosaic
command, etc..

Explains how to stitch two images into one, and how to use features
unique to the software: Auto and Intelligent Stitching.

Gives definitions of the special terms used in this manual.

Lists the key and key/mouse combinations you can use with this software.

Lists all the icons appearing in the software and their corresponding
functions.



Presto! ImageFolio is a comprehensive image processing program that
runs under MS Windows. It allows you to process images such as
photographs, graphics, and drawings, as well as images captured from
video devices such as a VCR, a laser disc, a CamCorder, etc. You can
also create new images with the powerful drawing tools included with
this software. With Presto! ImageFolio, your imagination is your only
limit!

Presto! ImageFolio allows you to save and transform images in a variety
of file formats.  This will give you the flexibility to use your images in
your favorite applications.

Presto! ImageFolio is an easy to learn Windows-based application.  It
will be easier to learn Presto! ImageFolio if you’re already familiar with
basic the MS Windows operating system.

What Presto!  ImageFolio Can Do

Ø Captures images with flatbed or hand held scanners and image capture
cards



Ø Supports both scanning & video image capturing within one working
screen

Ø TWAIN interface support to communicate with compatible image
sources

Ø Loads and saves images with various popular file formats such as TIF,
PCX, BMP, TGA, GIF, JPG, PCD, PSD, RLE, PCT, WMF, IMG, etc.

Ø Black & White, 16/256 grayscale, index 16/256 color, and 24-bit true
color image formats 

Ø JPEG compression/decompression file format to save disk space

Ø Scaling output for desktop publishing applications

Ø Printer Gamma adjustment to enhance image output effect

Ø Monitor Gamma adjustment to improve image display quality

Ø Halftone patterns for Black & White and color image printout

Ø Auto & Intelligent image stitching for large-sized images - Patent
Pending

Ø Image Manager functioning as an image data base which also provides
utilities to sort and preview image files

Ø Windows compliant user interface with pull-down menus

Ø User-definable Icon Bar for quick, easy processing

Ø Image format conversion functions such as color to gray, 256-color to
24-bit true color, etc.



Ø Actual number of image colors (data formats) as well as assigned scan
mode independent from current display mode

Ø Multiple documents simultaneous processing

Ø Drag-and-drop floating images among documents 

Ø Palette editing function for the user to compose his or her own color
palette

Ø Image editing and photo retouching functions such as rotating, flipping,
inverting and rescaling

Ø Complete drawing and painting tools such as line, paintbrush, airbrush,
color gradation, eraser, zoom, text, eyedropper, free-hand rotate,
hue/saturation brush, brightness/darkness brush, blur/sharpen brush,
image hose, texture brush, etc.

Ø Fine-tuning options to adjust brightness, contrast, hue, saturation, tone
distribution (equalization) and so on

Ø Multiple filters as well as user-definable filters to produce special
effects such as smooth, sharpen, edge detection, emboss and mosaic

Ø Adobe plug-in filter interface

Ø Full selection tools for easy masking of irregularities.

Ø Mask saving and loading functions for applying mask outlines to
different images

Ø RGB and HLS color modes

Ø Zoom-in bit editing function for detailed image modification

Ø Windows-style on-line help



System Requirements

This section introduces the hardware and software required to run the
software efficiently.

Hardware Requirements

The following hardware devices are required to run the software:

Ø An IBM PC 386, 486 or compatible computer

Ø One 3.5" floppy disk drive

Ø One hard disk drive with at least 12 MB space available to hold the
program (2 MB for the software, and a minimum of 10 MB to be used
as virtual memory for efficient use of the program)

Ø At least 4 MB of RAM (preferably 8 MB)

Ø A Windows compatible pointing device (mouse, trackball, etc.)

Ø A graphics board (VGA, Super VGA, XVGA, 15/16 bit or 24- bit
Windows compatible display board) and appropriate monitor

Software Requirements

The software required to run Presto! ImageFolio includes:

Ø MS DOS or PC DOS, version 3.3 or later

Ø MS Windows 3.1 or Windows 95



Recommended System Configuration

To take full advantage of Presto! ImageFolio’s features, the following
additional hardware and software elements are highly recommended:

Ø 10 MB or more of virtual memory

Ø A scanner that supports TWAIN

Ø A TWAIN source manager if you already have a scanner installed

Ø A Laser printer supported by MS Windows 3.1



This chapter provides instructions to install the software. Before you
install the program, you should make a backup copy of the software to
guard against data loss.

Backing Up Your Software

As a safety precaution against damage to your original software disk or
CD-ROM, it is advisable to make working copies of it.  You should then
store the original in a safe place. Should anything happen to the copies
you can always recopy from the original.

Using the Mouse

In this manual, the term “mouse” actually refers to any kind of pointing
device; the term mouse is simply used for convenience. 

Most of your editing work involves using a mouse to select tools, the
color scheme, or when using the Icon bar and so on. With this software,
the left mouse button does most of the work. Here is a brief review of the
terminology involved in mouse operation:



Ø When you are instructed to “point” at an item, it means to move the
mouse pointer or cursor so that it is positioned over that item.

Ø When you are instructed to “click”, it means to quickly press and release
the left mouse button.

Ø When you are instructed to “double click”, it means to press and release
the mouse button twice in rapid succession.

Ø When you are instructed to “drag”, first move the pointer to where you
want to start dragging, press and hold down the left mouse button, and
move the mouse to drag your object. When you reach the desired
destination on the screen release the mouse button.

If there is no specific indication as to which mouse button to click,
double click, or drag, it usually means to use the left button. Clear
instructions are always given when the right mouse button must be
used.

Installing the Software

Follow the following steps to install the software:

1. Insert the CD-ROM into the CD-ROM drive.
2. Start Microsoft Windows.
3. Pull down the File menu in the Program Manager.
4. Choose the Run command. A Run dialog box will appear.
5. On the Command Line, type:

depending on which drive your CD-ROM is assigned to.
6. Click on the [OK] button.



7. A dialog box will appear asking you to select the input device(s)
installed in your system. Set the proper input device according to your
hardware configuration.

8. Click on the [OK] button. The Installation Program dialog box will
appear.
The installation program will install the software on drive C. Click on
the [New Install] button to continue the installation. If you want to
install the software on a different drive, enter the drive letter and click
on the button.
After installation, an application folder titled Presto! ImageFolio will
appear.

Setting the Virtual Memory

We recommend you set the virtual memory in your system to 10 MB. To
set the virtual memory. Virtual memory can be set from the Control Panel.
Refer to the manuals that came with Windows 3.1 or Windows 95 for
details on setting your virtual memory.



In this chapter, you’ll learn to start Presto! ImageFolio and go through its
basic functions.

Running the Software

To run the software, follow these steps:

1. Start Windows and open the software application.
2. Double click on the software icon. Presto! ImageFolio’s main screen

will appear. You can remove the logo image shown in the middle of
the screen by clicking the left mouse button once.



Title Bar

The title bar indicates the name of the software.

Menu Bar

The menu bar lists the available menus. In each menu, there is a pull-down
list of commands. 

To open a menu, click on the menu or press its underlined letter on the
keyboard while pressing and holding the [Alt] key.

To activate a command, point to it and click on the command name.

Title Bar Menu Bar

Icon Bar

Toolbox

Status Bar

Palette
Control

Image Editing Area



To close a menu without choosing a command, click anywhere outside
of the menu or press the [Esc] key.

Icon Bar

The icons in the icon bar offer quick and convenient access to several
menu commands. Below is a lost of the menu commands that also have
icons in the icon bar.

New, Open, Save As, Image Manager, Acquire,
Print

Fill, Composite Control, Select All, Invert Selec-
tion, Abandon Selection, Stitch

System Info, Document Info

Change Image

Click on the icons to execute the related commands.

Image Editing Area

The image editing area is the large portion in the center of the screen
where you can work on your image. The “Image Canvas” you actually
use to work on your image appears as a window in that area; it can be
moved and resized within the image editing area.

Palette Control

The Palette Control is used for color selection or canvas palette editing.
For more information see Chapter 5, Creating and Painting Images.



The number of colors that the image canvas can display is independent
of the system’s display mode. In other words, you can edit a 256-color
canvas even though your system only has a 16-color display. In such
a case, halftone patterns are used to simulate the 256 colors.

Toolbox

The Toolbox is composed of two major sections. the Selectors and the
Editing tools. For detailed explanation please refer to the section Creating
and Painting Images in Chapter 5.

Background Color
Foreground Color

Solid Color
Indicator

Color Channel
Setting Boxes



Status Bar

The Status Bar is located at the very bottom of the image editing screen.
The Status Bar consists of the status box, the message box, the toolbox
button, the tool control button, the palette control button and the icon bar

button.

Selectors:

Use the selectors when selecting a portion
of image for editing.

Editing Tools:

Use the editing tools to edit and/or apply special effects to
an image. Double click on the tool you wish to use.

Status Box

Message Box

Toolbox Button
Tool Control Button

Palette Control Button
Icon Bar Button



The status box displays the X,Y coordinates indicating where the pointer
is located on the active image window.

The message box displays a message about the item the pointer is
currently pointed at.  And you can move the pointer on any menu,
command or icon on the screen and press [F1] to bring up a  help message
about the item.

During processing, the status and message boxes indicate the command
you have selected and the progress of the operation. You may press the
[Esc] key to abandon the process before it is complete.

Clicking this button will hide the Toolbox. Click
again to display the Toolbox. Selecting the Show
Toolbox command under the View menu is equiva-
lent to clicking on this button. 

Clicking on this button displays the Tool Control
options menu. Click again to hide it. Selecting the
Show Tool Control command under the View menu
is equivalent to clicking on this button. 

Clicking this button hides the Palette Control from
the screen. Click again to display the Palette Con-
trol. Selecting the Show Palette Control command
under the View menu is equivalent to clicking on
this button. 

Clicking this button hides the Icon Bar. Click again
to display the Icon Bar. Selecting the Show Icon
Bar command under the View menu is equivalent
to clicking on this button. 



About On Line Help

In addition to the messages shown on the status bar, click on the Help
menu for more information about any of the functions, commands, and
dialog boxes associated with Presto! ImageFolio.

If you are not familiar with the Windows help system, open the Help
menu and click on Using Help for instruction.

Exiting the Software

To quit the software, select the Exit command under the File menu.

If your image has been modified and not saved yet, a dialog box will
appear and prompt you to save the file. Click on the [Yes] button to save
the image. Click on the [No] button to ignore the image modification and
exit the software. Click on the [Cancel] button to quit the Exit command.



All your image canvases are recognized as files by the computer. There-
fore, when you’re working with files, you’re actually dealing with the
image canvases. You may prepare a new image canvas, open an existing
canvas, store a painted canvas, print out the image, or even deal with
several image canvases at the same time. Most of these functions are
executed from the File menu.

Setting Up for New Images

Before creating a new canvas for your image, you should set some of the
image processing options in the Preferences dialog box. For example,
you should enter a monitor gamma value so that your monitor will display
the color of the image more precisely. To set the options in the Prefer-
ences dialog box, choose the Preferences command from the File menu.
The Preferences dialog box appears as shown on the next page.

Calibrating the Monitor

The Monitor Gamma option allows you to adjust the RGB channels
precisely according to the monitor you use.  This will allow you to view
images in their real colors on your screen.

To set Monitor Gamma, follow these steps:



1. Select Preferences from the File menu. The Preferences dialog box
will appear.

2. Enable the Monitor Gamma option (click in the check box) and click
on the [Set Gamma Value] button. The Monitor Gamma dialog box
will pop up.



3. Select Separate to adjust the RGB channels separately, or All to adjust
the three channels at once.

4. Drag the triangle sliders  left or right to adjust the levels.  Or you can
adjust the levels by clicking in the All box and move its triangle slider.
You can also type in the gamma values directly for a more precise
setting.

5. Click on the [OK] button to record the gamma value.
6. In the Preferences dialog box click on the [OK] button to enable the

new setting.

Setting the Temporary File Directory

Presto! ImageFolio allows you to reserve part of the system memory for
other applications. And when it requires more memory to work on
images, it generates temporary files in a user-specified directory which
is recognized as extra memory space. These temporary files are automat-
ically removed when you exit the software.

Set the amount of reserved memory with the Minimum Free Memory
option, and the directory for storing temporary files with the Cache Path
option.  These options are accessible from the Preferences dialog box.

Creating a Canvas

The New command creates a new canvas. To create a new canvas, do the
following:

1. Open the File menu and select New or click on the New icon on the
icon bar. The New dialog box will appear.



2. Select the image type for your image. The image type indicates the
number of colors to be used in creating your image. The following
table illustrates the number of colors used for each type:

Black & White 2

Index 16 Gray 16 shades of gray

Index 256 Gray 256 shades of gray

Index 16 Color 16

Index 256 Color 256

24-bit True Color 16.7 million

The number of colors that the canvas can display is independent of
the display type. This means that you can edit a 256 color canvas, for
example, even if your system only has a 16 color display. In that case,
halftone patterns are used to simulate the 256 colors.



3. Enter the image resolution in the Resolution text box. Higher resolu-
tions provide better images, but they use more disk space and take
more time to process.

4. Click on the Image Size pull down list to select the size of your image
canvas.
Enter the size in the Custom text boxes if you select the Custom Define
option. And select the appropriate unit from the pull down list box.
The amount of memory required to create the canvas and the amount
of available free memory are displayed at the bottom of the dialog
box.

5. Click on the [New] button. A new canvas will be created with an
untitled filename.

Each image canvas appears as an image window in the image editing
area. If the image canvas is actually larger than the image window,
two scroll bars appear. The scroll bars allow you to scroll the image
vertically and horizontally so you can view hidden parts of an image.
The rulers can help you edit precisely. If you don’t want the rulers,
you can hide them by choosing the Show Ruler command under the
View menu. You can also change the ruler’s measure units from the
Preferences dialog box.

Image Filename

Ruler

Scroll Bar

Scroll Bar



Loading Images into the Image Editing Screen

There are several ways to load existing images into the image editing
screen. You can use the Open command, the Image Manager command,
and the Recall command. Or you can acquire images from TWAIN
compliant hardware devices, and capture  images from video devices.

Opening a File

The Open command is used to load an already existing image file. To
open an image file, follow these steps:

1. Open the File menu and select Open, or click on the Open icon on
the icon bar. The Open dialog box will appear.

2. If the file you want to open is on a different drive, select the drive you
want from the Drives box.

3. In the Directories box, choose the directory you want to open a file
from.

4. From the list of files, select the file you want to open.

Select a drive letter or
directory name

Type the name
of the file you
want to open.



You can open multiple files by clicking 1) on the file names while
holding down the [Ctrl] key.

5. If you’ve selected  to  open  a  Photo  CD  format  file  (*.PCD),  you
may click on the [Option] button to set the resolution and image type.

6. Click on the [Info] button to view the file information. The File
Information dialog box will appear.
Click on the [OK] button to return to the Open dialog box.

7. Click on the [OK] button in the Open dialog box to open the file.

When you open several image files simultaneously, you may choose to
use a different color palette for each image, or use a common palette
for all the images. Just keep in mind that different images may have
been processed with different color palettes.  If you choose to view each
image using a separate palette,  the color palette of the active image
will change all the displayed colors in the inactive background images.
Use the View Images with Common Palette option in the Preferences
dialog box to make your choice.



Previewing Files

The Image Manager command under the File menu allows you to view
an image before you open it so you’re sure its the image you want opened.
Image Manager can also be used to open, copy, rename, and delete files.

To open Image Manager, open the File menu and select Image Manager,
or click on the Image Manager icon on the icon bar. The Image Manager
window will appear.

To preview the file(s), follow the steps below:

1.   Select the drive you want from the Drives box.
2. In the Directories box, locate the files you want to open.
3. Click on the Refresh icon in the middle of the dialog box. A thumbnail

copy of the images will appear in the film boxes.



By default, files are displayed by filename in alphabetical order. You can
also choose to display files by size, or by date.



To view the information about an image file, select the image’ s film box,
then click on the Information icon to bring up the Image Information
dialog box.

To copy a file:

1. Select the thumbnail of the image you want to copy.
2. Click on the Copy icon. A text box appears at the right of the Rename

icon with the current directory name displayed.

3. Move your mouse pointer to the text box and enter the new directory
or file name of the image you want to copy.

4. Click on the  icon at the right of the text box to copy; click on the
 icon to cancel the process.

To rename a file:

1. Select the image preview of the image to be renamed.
2. Click on the Rename icon. An empty text box will appear to the right

of the icon.
3. Move your pointer to the text box and enter the new file name for the

image.
4. Click on the  icon at the right of the text box to rename; click on the

 icon to cancel the process.



To delete a file:

1. Select the image preview you want to delete.
2. Click on the Delete icon.

To delete multiple files:

1.   Press on the [Ctrl] key while clicking on each of the  files you want to
   delete.
2. Click on the Delete icon.

To load a file into the image editing screen:

1. Select the image film box. The file name will appear in the File Name
box at the top left corner of the dialog box.

2. Click on the [OK] button.

To load multiple files on the image editing screen:

1. Press and hold the [Ctrl] key while clicking on each of the files you
want to load.

2. Click on the [OK] button.

You can review a file’s last saved date and size in the current directory
by clicking on the File List icon. 

You can add image previews into the Image Manager when you save
files. You can enable or disable this function by clicking on the Build
Thumbnails When Saving Image option in the Preferences dialog
box.



Recalling Files

You can quickly open any of the last few images you worked on by
choosing the Recall command from the File menu. The number of files
the software can recall depends on the setting of File Recall Level in the
Preferences dialog box.

Acquiring Images from TWAIN Sources

Presto! ImageFolio gives you access to images from any input device
with a TWAIN driver interface, such as a scanner.

If you plan to use an input device that has a TWAIN driver, you should
first install the driver provided with the hardware  before entering image
data from it into Presto! ImageFolio.

To input an image using a TWAIN source, open the File menu and choose
the Select TWAIN Source command. A dialog box will appear.

All the TWAIN sources installed on your system will be listed in the
Sources box. Click on the device you want to use and press the [Select]
button. Then open the File menu again and select the Acquire command,
or click on its icon on the icon bar. The dialog box designed by your
hardware manufacturer will appear.  Refer to your hardware manuals to
set the parameters in this dialog box.

Saving Images

After editing your image, you may want to save it for future use.



Save As

This command saves a new or previously existing file. You can name a
new file or save an existing file under a new name and preserve the
original file in its previously saved form. To save a new or existing file:

1. Open the File menu and click on Save As, or click on its icon on the
icon bar. The Save As dialog box will appear.

2. Select the drive you want from the Drives box.
3. In the Directories box, choose the directory you want to save the file

in.
4.  Use the List Files of Type box to choose the image type.

If you select the JPG compressed file extension, you need to set the
compression level by clicking on the [Option] button.  For more
explanation, refer to the section Saving with JPEG Image Compres-
sion on the next page.

5. Name the image in the File Name box.



6. Click on the [OK] button to save the image, or click on the [Cancel]
button to cancel the process.

The JPEG Compression feature is included with Presto! ImageFolio to
save disk space. To compress a file before saving it:

1. Select JPEG from the List Files of Type pull down list.
2. Click on the [Option] button. The JPEG Compression Control dialog

box will appear.

3. Drag the pointer in the scroll box to select a compression level. This
determines how much an image is compressed. The higher the level,
the greater the amount of compression.

4. Click on the [OK] button.
5. Go to the File Name box to enter a filename.
6. Click on the [OK] button.

The JPEG Information box will display the final compression ratio,
image size, etc.



Save

Save is used to save an image that already exists on disk. After saving, you can
keep on working on the image. It’s a good idea to save often to prevent accidental
loss of changes you’ve created.

To save changes made to your image, open the File menu and select Save. The
keyboard shortcut is [Ctrl]+[S].

Printing an Image

Before printing an image, you may want to change the printer configuration or
the output format.

Changing the Printer Configuration

The Printer Setup command allows you to change the settings on your printer.
To change the default settings, follow these steps:

1. Open the File menu and click on Printer Setup. The Printer Setup dialog box
will appear.

2. Make all necessary changes.



3. Click on the [OK] button to save the changes and return to the image
canvas. Click on the [Cancel] button to close the box and return to
the image canvas without saving the changes made.

Setting Up Image Output Format for Printing

The Print command under the File menu provides users with different
options for printing and image output formats. To print an image:

1. Open the File menu and choose Print, or click on its icon on the icon
bar. The Print dialog box will appear:

The information about the current printer, port configuration, and
page orientation are displayed in the upper part of the dialog box.
These can only be changed through the commands in the Printer
Setup dialog box. If you want to change any of these items, click on
[Setup] at the bottom of the box.

2. Enter the number of copies you want to print.



3. The Set Margin section allows you to set the top and left margins. You
may also choose to print the image horizontally or vertically on the
middle of a page.
You can change the position’s coordinates and units from the Units
pull down list.

4. Click on the Rescale to Fit the Page check box if you want to rescale
the image in relation to the size of the paper used.

5. Click on the Use Printer Default check box in the Halftone Image
option if you want to use the printer default halftone pattern.
Click on the [Set Halftone] button to select a halftone pattern. Please
refer to the section entitled Converting Images in Chapter 7 for more
explanation on selecting the halftone pattern.

6. Click on the Add Frame option if you want to add a border to the
image, and select the type of border you want to frame your image
with.

7. The Tone Map option calibrates the image printing quality. This
function is similar to the Monitor Gamma function in the Preferences
dialog box. If you need to precisely adjust the printing quality, click
on the [Tone Map] button to open the Tone Map dialog box. Refer to
the section later entitled Printer Calibration for details on setting the
printing tone map.

8. Click on the [Print] button to print.

The [Set Halftone] button is only enabled when the Use Printer Default
option is disabled.

Rescale allows you to change the size, resolution and scaling factors of
the image you want to print. To rescale an image:

1. Click on the [Rescale] button. The Rescale dialog box will appear.



2. You can set the scaling ratio by entering its size in the Target Image
section or by entering the X (horizontal ratio) and Y (vertical ratio)
values in the Rescale Factor. You can also specify the scaling ratio
by dragging the pointer in the scroll bars between the 10% and 1000%
values indicated.
If you have enabled the Keep Ratio option, you can enter either the
width or the height of the rescaled image. The software will automat-
ically determine the other value for you.
If you have disabled the Keep Ratio option, you have to enter both
the width and height to rescale the image. If the values you enter are
not proportional, the rescaled image will be distorted.

3. Enter the horizontal and vertical resolutions in the Resolution text
boxes.

4. Click on the [OK] button to save your setting and return to the Print
dialog box; click on the [Cancel] button to return without rescaling.

Displays the original
size and resolution of
the image.

Click here to change
the unit.

Click on this check box
if you don’t want to
keep the proportion of
the original image.



You can calibrate the printing quality precisely by adjusting the mapping
curve in the Tone Map dialog box.

To adjust the printer mapping curve:

1. Select Print from the File menu.
2. Click on the [Tone Map] button in the Print dialog box. The Tone

Map dialog box will appear.



3. Select the color channel you want to calibrate as All, Red, Green or
Blue.

4. Click on the [Enhanced Function] button to open a function list which
includes several options for calibrating the printing quality. 

5. If none of the options meet your requirements, you may set the
mapping curve as you need. You can enable the Show Control Points
option to display the control points on the mapping curve and adjust
the location of the control points. Then click on [Smooth] to have the
software start calculating the modified mapping curve.
The Accumulatively option is used when you want to add the feature
of one of the functions in [Enhanced Function]. You can first enable
the Accumulatively option, and then select the features from the
function list. The mapping curve will include all the features you
selected.
You can save the modified curve with the TON file extension by
clicking on the [Save] button and loading a pre-defined curve with
the [Load] button.

6. Click on the [OK] button to close the dialog box and return to the
Print dialog box.



Managing Multiple Images

Presto! ImageFolio enables you to perform multitasking. The number of
documents you can open depends on your system’s memory.

The commands in the Window menu enable you to manage all of the
windows on screen. The Cascade command arranges the windows in a 

diagonally overlapping pattern. The Tile command arranges the windows
so that all of the windows can be seen at once. The Arrange Icon
command arranges the icons evenly across the bottom of the windows.

If any of the simultaneously opened documents temporarily does not need
editing, We recommend you minimize it as an icon. It can then be
displayed as a shrunken copy of the image, and placed at the bottom of
image editing area by clicking on the down arrow at the upper right corner
of the image window.

To maximize an image, double click on its icon or select the Maximize
command from the Window menu.

To close all the documents on the screen at the same time, select the Close
All command under the Window menu. If any of the documents modified
has not yet been saved, a dialog box will pop up asking you to save it.
Click on the [Yes] button to save the image; click on the [No] button to
ignore the image modification.

If you’re sure that all desired modifications to the images have been
saved, you can close all the documents with the Quick Close command
instead of Close All. The software will not prompt you for any unsaved
processing of the images.



Information

The System Info and Document Info commands under the View menu
provide information about system memory and the active image.

In the Document Info dialog box, the [Previous] and [Next] buttons allow
you to view the previous and next document information. Click on the
[OK] button to close the dialog box.





Converting File Format

The Convert Format function enables you to convert file format and
image type without opening the images in Presto! ImageFolio. For
example, you can convert a BMP file into a TIF format, or a 24-bit true
color image into an Index 256 color image.

To convert images:

1. Select Convert Format from the File menu. A dialog box appears as
follows:

2. Select the drive you want from the Drives box.
3. In the Source Directories box, choose the directory where the file(s)

you want to convert are located.
The Files box displays the names of all files in that directory that are
of the type selected in the Source Files of Type box.



4. In the Files box, highlight all the files you want to convert.
5. Whenever a file is highlighted, you may click on the [Info] button to

view the file information.
6. Click [Add] or [Add All] to add the highlighted files to the Selected

Files box. If you want to remove any file in the Selected Files box,
highlight the file and click the [Remove] button.

7. In the Target Directories option, select the directory where  the
converted file(s) should be placed.

8. Use the Target Files of Type box to select the file format you want
the images converted to.

9. If you want to convert the image type of the files, click the [Option]
button. Please refer to the section entitled Converting Image in
Chapter 7 for more information about selecting target image type and
converting method.

10. Click on [Manual Convert] or [Auto Convert] to start converting the
files.  Manual Convert opens the Change Image dialog box for each
file. Auto Convert uses the Option setting to convert all the files. 

11. After the conversion is finished, click on [Exit] to close the dialog
box.



The Toolbox contains all the tools you need to create or edit an image.

For your convenience, the Toolbox can be dragged to a different part
of the screen. It can also be hidden by choosing the Show Toolbox
command from the View menu. Click on the little box in the upper left
corner of the Toolbox,  or click on the Toolbox button on the status bar.

Before using the tools to create or paint your image, you should learn how
to select a color and how to manage the color palette.

Palette Control Options

Each image canvas has its own color palette. The default color palette for
the active image canvas is generated according to the image type you
specified in the New dialog box. For example,  if you selected the image
type “Index 256-Color”, a color palette containing 256 colors is attributed
to the image canvas. If you selected “24-Bit True Color”, your color
palette contains 16.7 million colors.



Buttons

The [View] and [Tools] buttons were built in with several icons for palette
editing. Clicking on these buttons brings out the icons. We'll discuss the
functions of these icons later.

The [HLS] button is used to toggle between RGB and HLS color modes.
When the current color mode is RGB, clicking on the [HLS] button
changes the color mode to HLS and vice versa.

Foreground/Background Color

The foreground and background colors are selected from the color palette
with the color picker (down/up arrows) at the right of the Primary Color
Palette window. When you select a color, if the foreground color indicator
(square) is clicked, a frame will appear around the foreground square;
this means that the foreground color indicator is activated. Click on a
color from the color palette with the left mouse button to select a
foreground color and the right button to select a background. If you
clicked first on the background color indicator, then the background color

Foreground Color
Background Color

Color Channel
Setting Box Primary Palette

Solid Color
Indicator

Spectrum Scratch Pad



is active. In this case, click with the left mouse button to select a
background color, and right button to select a foreground color.

Color Channel Setting Boxes

Besides picking colors from the Primary Palette, you can also set the
value of each color channel (like the red, blue and green in RGB mode)
to compose a color that is not in the primary palette. Click on the up or
down arrow at the right of the boxes or type the values in directly to make
the setting.

Solid Color Indicator

The solid color indicator shows the color in the primary palette. The
Foreground or Background color indicator displays the actual color
specified in the color channel boxes.  Because a color specified with the
color channels may not be represented in the primary palette’s color
spectrum, the solid color is the one used to paint on the canvas.  In color
modes other than 24-bit true color, only solid colors can be applied to
canvas.

Selecting Colors

There are two ways to select colors: one is from the image, and the other
is from the color palette. To select a color from the image, use the
Eyedropper tool. To select a color from the color palette, use the Color
Picker.

Eyedropper

The eyedropper selects color from a pixel in an image. This means that
even though you may not be sure of which color it corresponds to on your
palette, you can still select the exact color you want from the image. To



pick a color, select the Eyedropper tool from the Toolbox and click on
any color from the image (click the left button to select a foreground color,
and click the right button to select a background color).

Color Picker

To select a color from the color palette, move the pointer into the color
palette area and click on the color you want to select.

Editing the Color Palette

You can change the color composition on the palette through the Palette
Control commands. Or you can open the universal color spectrum to pick
colors from a second color palette.

To edit a customized palette, you select colors from the universal spec-
trum and use the scratch pad for creating a new palette. Click on the
[View] button, and three tool icons appear to the right. These icons allow
you to turn the spectrum, the primary palette, or the scratch pad on and
off.

The palette in the scratch pad is completely independent of the current
canvas type. You may pick colors from the spectrum or primary palette
to display in the scratch pad.

The table on the next page  lists the effects of keyboard/mouse operations
while editing the color palette.



Click Mouse Left Button Pick a foreground or background color

[Shift]+Click Left Button Select or deselect colors

[Shift]+Click Right Button Deselect all the currently selected color

[Shift]+Drag through a
block of colors

Select a block of colors

[D] Delete the selected colors

[Ctrl]+Click Left Button Insert the selected colors starting from
the color grid you are now on

[Alt]+Click Left Button Replace the colors of the color grid you
are on with the selected ones

To replace colors, press the [ALT] key and click. The mouse pointer
changes to a Paint Bucket.

To insert colors, press the [CTRL] key and click. The mouse pointer
changes to a Paint Bucket with a plus sign.

To select multiple colors, press the [Shift] key and drag through the block
of colors. The mouse pointer changes to a cutter with a plus sign.

In the primary color palette, you can only select or deselect colors. You
can't delete, insert, or replace colors.

Managing Color Palette

The icons below will appear when you click on the [Tools] button.

Save as File

Saves the palette in the scratch pad with a  extension.



Load from File

Loads a palette from a file previously saved with its  extension.

Append from File

Appends colors from a  file into the scratch pad according to the
current color grid in the scratch pad.

Load from Primary Color Palette

Loads all the colors from the primary palette into the scratch pad.

Save as Primary Palette

Uses a whole scratch pad palette as your primary palette. The Set Convert
dialog box will appear, and you can then select a way to convert the
image’s color scheme. If you select the Pseudo Color option, Presto!
ImageFolio will use the color grid of the new palette for color conversions
of your image. In 24-bit true color mode, this function works by reducing
palette colors according to the colors in new palette. 

Get Colors Used Most from Canvas

In 24-bit true color mode, Presto! ImageFolio will get the 256 colors used
most in the canvas. In color modes other than 24-bit true color, this
function produces the same effect as Load from Primary Palette.

Create Gradation of Colors

Creates a gradation of colors between foreground and background colors
(in the scratch pad). First, select a blocked area in the scratch pad, then



click on this icon to create a gradation of colors from foreground to
background colors in the blocked area.

Sort by Hue

Rearranges the color order in the scratch pad by the sequence of colors
in the HLS color wheel.

Sort by Tint

Sorts the colors in the scratch pad by color tint, from lightest to darkest.

Tool Control Options

The Tool Control options determine how a tool behaves. For example,
you may want to change the thickness of the line when drawing a
rectangle with the Rectangle tool.

There are several ways to bring up the Tool Control options:

The Tool Control options vary for different tools. The table on the next
page indicates the options available for the different tools.



Size

The Size option is used to specify the line width or the size of the selected
tool. Click on the up and down arrows at the right of the text box to change
the size setting, or type the value directly into the text box and press
[Enter].



Transparency

The Transparency option allows you to adjust the transparency degree of
your tool. More of the image underneath your selection area can be seen
as you increase the transparency percentage of that tool. Click on the up
arrow to increase the transparency setting or down arrow to decrease it,
or type the percentage directly into the box.

Feathering

The Feathering option allows you to soften the covering effect of the
edges of your tools by softening the edge color into the background. Click
on the up arrow to increase the setting and soften the edges of the tool,
the down arrow to decrease the setting and sharpen its edges, or type the
percentage directly into the box.

Shape

This option offers several types of shapes for your painting tools. For
example, you can choose a round or a square paintbrush to paint an image.



When you are using the Stamp tool, the Shape option determines the shape
of the stamp as square or circular.

Pattern

Presto! ImageFolio offers several tool effects or patterns you can apply
to graphics. Click on the pop up list box and select a pattern.

Range

When using the Magic Wand tool, this option is designed to set the range
of a selected color. If the color range is set to 1, the magic wand will only
select pixels from the image if they're exactly the same as the one you
picked for the tool's effect. When you set a higher value in Range
(maximum of 255), the selector will also affect different tints in the area
selected. 

When using the Paint Bucket tool, this option sets the surface range of a
given color area. The filling range is decided by a color pixel from the
image as well as by the tint you set for the replacement color. 

Style

The option allows you to draw hollow, framed or solid color rectangles
and ellipses. Click on the pop up list and select a style for the tool you're
going to use.

Pressure

This option is available only when using the Airbrush. Use this option to
specify the airbrush's color intensity. The pressure range is from 10% to
100%.



Selecting the Image

You can edit a selected portion of an image without affecting the rest of
the image. Use the selectors to select the portion of image you want to
change.

To expand the portion of an image you previously selected, press and
hold the [Shift] key while selecting the area of the image with the
selectors.

To reduce a portion from your previous selection, press and hold the [Ctrl]
key while selecting the area to be excluded with the selectors.

To abandon the selection altogether, do one of the following:

Rectangle Selector

This selector allows you to select a rectangular portion of an image. To
select a rectangular portion:

1. Click on the Rectangle Selector.
2. Place the mouse pointer anywhere within the image.
3. Press and hold the left mouse button.
4. Drag the pointer diagonally to the opposite corner of the area you want

to select.
5. Release the mouse button. The selected portion of image will appear

in a rectangular frame.
Note: You may select a perfect square, rather than a rectangle, by
holding down the [Shift] key while using the Rectangle Selector.



Ellipse Selector

This selector allows you to select an elliptical portion of  an image. To
select an elliptical portion:

1. Click on the Ellipse Selector.
2. Double click on the Ellipse Selector icon to bring up the Tool Control

window.
3. Select to draw the elliptical outline from either its rim or center in the

Tool Control option.
4. Place the mouse pointer anywhere within the image.
5. Press and hold the left mouse button.
6. Drag the pointer diagonally until you've selected the portion you wish

to capture.
7. Release the mouse button.

Note: You may select a perfect circle, rather than an ellipse, by
holding down the [Shift] key while using the Ellipse Selector.

Free-hand Selector

This selector allows you to select an irregularly shaped portion of an
image. To select an irregular portion:

1. Click on the Free-hand Selector.
2. Move the pointer to the beginning of the irregular edge.
3. Click and hold the left mouse button.
4. Hold down the mouse button and drag the pointer around the image

portion you wish to select. 
-or-
Release the mouse button and drag the pointer to one of the edges of
the object you want to select.  A straight line will follow your pointer.

5.  Click on the edge and move your pointer to another edge.



6. Keep on selecting using the same procedure until the entire object has
been selected.

7. Double click to finish the selection.

Magic Wand

This tool automatically defines the outline of the area to be selected
according to a specific color range set by the user. It selects a portion of
image from the color pixels or from the color definition of that image
portion.

1. Click on the Magic Wand icon.
2. Set the Tool Control options by double clicking on the Magic Wand

tool.
3. Click on the color you want to select from the image.

Selector Brush

This tool works like a free-hand brush and defines enclosed selections
according to the width and shape the brush is set at. To use the Selector
Brush, follow these steps:

1. Click on the Selector Brush icon.
2. Move the mouse pointer to the point in the image you want to start

selecting.
3. Press and hold the left mouse button as you move the mouse pointer

to draw your selection.
Press the right button while going over the same area if you want to
deselect the area just drawn.

4. Release the mouse button.



Moving the Outline

After a selection is defined, The Move Tool allows you to move the
selection to other parts of an image. To move a selection:

1. Click on the Move icon.
2. Move the mouse pointer to the selected frame. The shape of the mouse

pointer changes to a four-arrowed cross.
3. Click and hold the left mouse button.
4. Drag the selected frame to a new location.
5. Release the mouse button.

Image Editing Tools

Image editing tools are located in the lower portion of the Toolbox. To
select a tool, simply click on it.

You can set the tool control options for one of these tools by clicking on
its icon. Please refer to the Tool Control Options section for more
explanation.

Pan

This tool enables you to move an image within its own canvas. This is
helpful if the image is larger than the canvas, and you want to edit some
part of it that is unseen on screen. Pan allows you to move any portion
of the image into view. Using Pan is similar to using the scroll bars except
that you can move your image horizontally and vertically simultaneously
within the canvas. To use the Pan Tool:

1. Click on the Pan icon.
2. Place the mouse pointer on the image.



3. Press and hold the mouse button as you drag the image across the
canvas.

4. Release the mouse button.

Line

Use the Line tool to draw straight lines. To draw a straight line:

1. Click on the Line tool.
2. Set the Tool Control options by double clicking on the Line tool.
3. Press and hold the left mouse button.
4. Drag the pointer to draw a line.
5. Release the mouse button.

Holding the [Shift] key while drawing the line produces a horizontal,
vertical,l or 45 degree slanted line.

If you want to draw a line adjacent to the previously drawn line, hold the
[Ctrl] key while clicking the left mouse button at the ending point of the
adjacent line. 

Ellipse

Use this tool to draw ellipses or circles. The Ellipse Tool works just like
the Ellipse Selector, except it draws an ellipse rather than selecting one.
To create an ellipse, follow these steps:

1. Click on the Ellipse icon.
2. Double click on the Ellipse icon to bring up the Tool Control options.
3. Select to draw the ellipse from either its rim or its center.
4. The REPEAT option enables you to draw several ellipses at one time.
5. Move your mouse cursor to the canvas.
6. Press and hold the left mouse button.



7. Drag the pointer diagonally across the canvas. An ellipse will appear.
8. Release the mouse button.

To draw a perfect circle, hold down the [Shift] key while dragging the
mouse.

Rectangle

This tool is used to create rectangles or squares. It works just like the
Rectangle Selector, except it draws rectangles rather than selecting them.
To draw a rectangle:

1. Click on the Rectangle icon.
2. Set the Tool Control options by double clicking on the Rectangle tool.
3. Move the mouse pointer to the image canvas.
4. Press and hold the left mouse button.
5. Drag the pointer across the image. A rectangle will appear.
6. Release the mouse button.

To draw a square, hold down the [Shift] key while dragging the mouse.

Paintbrush

This tool allows to draw lines as if you were using a real paintbrush. To
draw with the paintbrush:

1. Click on the Paintbrush tool.
2. Set the Tool Control options by double clicking on the Paintbrush

tool.
3. Move the pointer to the image canvas.
4. Press and hold the left mouse button to paint with the foreground

color, or the right mouse button to paint with the background color.
5. Drag the pointer across the screen as if you were painting on a canvas.
6. Release the mouse button.



Airbrush

The airbrush sprays color pixels on an image, giving it an impression of
depth. To use the airbrush:

1. Click on the Airbrush tool.
2. Set the Tool Control options by double clicking on the Airbrush tool.

Two kinds of shading effects can be produced by the Airbrush tool.
The SPATTER option generates splashed color pixels, and the FAT-
TING option produces smooth gradations of foreground color.
The PRESSURE option influences the density and thickness of the
airbrush.
The SPACING option determines the space between the sprayed
points.

3. Drag the pointer across the image. Use the left mouse button to apply
the foreground color, and the right mouse button to apply the back-
ground color.
Note: The speed at which you drag the pointer will affect the spray’s
appearance.

4. Release the mouse button.



Paint Bucket

The Paint Bucket enables you to fill an image selection with a specific
color. It fills the foreground color of a selected area with another color
according to the calculated range of the original color.

To use the Paint Bucket:

1. Click on the Paint Bucket tool.
2. Set the Tool Control options by double clicking on the Paint Bucket

tool.
3. Move the pointer to the portion you selected.
4. Click on the left mouse button to fill the area with the foreground

color.

Note: If the area you want to fill is not completely enclosed, the paint
bucket color will “leak” and fill the surrounding area with that same color
(or a certain range of it).

Gradation

This tool enables you to create a gradual transition from the foreground
color to the background color, or color gradation of multiple colors with
a linear, radial or square shape.

You can select multiple colors to create a “rainbow” color gradation. In
the Tool Control options, you can select the direction of gradation as
linear, radial or square.

To create a color gradation,follow these steps:

1. Use a selector tool to outline the area you want the gradient colors
generated. If there is no such selection made, Presto! ImageFolio will
generate a gradation of colors for the whole canvas.

2. Select the Gradation tool.
3. Bring up the Tool Control options by double clicking on the tool icon.



4. In Tool Control window, select an option for gradient colors by
pulling down the OPTIONS list. The “FG & BG” option generates a
gradual transition from the foreground color to the background color.
The “MULTICOLOR” option lets you use many colors in your gra-
dation.

5. Set the color transition manner as RGB or HUE by the Mode pull-
down list.
The RGB option changes the colors according to the colors you
specified. The HUE option generates the gradation according to the
color sequence on the HLS color wheel: HUE - option creates color
transition in clockwise sequence; and HUE + option creates color
transition in counterclockwise sequence on the color wheel.
You can create a “rainbow” color gradation by using the HUE mode.

6. Select the colors you want to use for generating color gradation.
If you have selected “FG & BG” option, select the foreground and
background colors.
If you have selected “MULTICOLOR”, move the pointer inside the
selection frame and click the right mouse button. A dialog box will
appear.



The Choose pull-down list includes several pre-defined gradations
for your application.
The Color box shows the selected color each time you pick a color
from the spectrum or primary palette. If the color you want to choose
is not shown in the palette, you can type in the values of RGB or HLS
channels to specify the color. 
Click and drag the selected color to the color strip in the middle of
the dialog box. The first color you choose will automatically be
identified as the color on the starting point of the color strip and shown
in the Start color box. The second color you pick will be identified
as the color on the ending point of the color strip and shown in the
End color box. Other colors you pick will be placed where you drag
and release the mouse button. A color flag will appear on the top of
the color strip to identify the exact location of the color. These flags
can be dragged to a different location in the color strip. If you drag a
flag out of the range, that color will be removed from the color strip.

If you want to make the space between the selected colors the same,
click on the [Equalize] button.
After you’re satisfied with the color gradation in the color strip, you
can save it by clicking the [Save] button and you can recall the
gradation later with the [Load] button.
Click on [OK] when you have finished working on the colors.

7. Select the shape of gradation as linear, radial or square from the
SHAPE pull-down list.

Linear Gradation Radial Gradation Square Gradation



8. Move the mouse pointer inside your selection.
9. Press and hold the left mouse button.
10. Drag the mouse cursor to the ending point of gradation.
11. Release the mouse button.

Eraser

This tool erases all the pixels it passes over except for those of the
background color. That is, it paints over the image with the background
color. Because you can set the transparency of erasing, the image can
look as if blurred while the cursor passes through it. To use the Eraser:

1. Click on the Eraser tool.
2. Set the Tool Control options by double clicking on the Eraser tool.
3. Set the eraser size for processing. If you want to erase foreground

color only, select Fg. Color in Options; if not, select All Colors
instead.

4. Move the pointer to the image.
5. Press and hold the left mouse button as you drag it over any part of

the image you want to erase.
6. Release the mouse button.

Text

You can enter text anywhere on an image with the Text tool. Presto!
ImageFolio supports all the fonts installed in Windows. To enter text:

1. Click on the Text icon.
2. Double click the Text icon to bring up the Tool Control options.
3. Click on the down arrow in Tool Control to display a list of envelope

shapes and select the one you want to use.
If none of the envelopes in the list are similar to the text shape you
need, you may select freehand reshaping to define your own envelope.



4. Move the cursor to where you want the text to start and click. A Font
dialog box will appear.

5. Select the font, the font style, and the character size. The Sample box
will display an example of the selection you made.

6. In the Effects window, decide whether or not you want the text to be
stricken through or underlined.

7. If you want the text character to be placed vertically, enable the
Portrait option.

8. Enter the text in the Text box.
9. Click on [OK] to input the text.
10. A rectangle with eight square nodes around the text will appear on

the canvas. Drag the nodes to change the shape and size of the text.
If you selected freehand reshaping, more nodes will appear for your
adjustment of the text shape. Use the hand pointer to drag and form
your text envelope.

11. If you have defined your own envelope by freehand reshaping, after
you have completed adjusting the text shape, you can save the
envelope for further use. Select Envelope from the Edit menu and
choose Save from the pop-up submenu. The envelope is saved with



ELP file extension. You may recall the envelope later with Enve-
lope/Load command when you select freehand reshaping.

12. Click the right mouse button to fix the text shape.

The added text will be automatically outlined for further editing. After
you finish, abandon the selection to fix the text on the canvas.

Stamp

The Stamp tool has two different functions: one is like a stamp which
copies (stamps) an image portion to another area  of the image. The other
is the cloning feature which can trace an image or part of an image with
specified shape, transparency, and feathering options.

The clone function can create different effects with one image, combine
several pieces of images into one, and generate tiled pattern from an
image. 

To use the stamp:

1. Click on the Stamp tool.



2. Open the Tool Control window by double clicking the Stamp icon.
3. Select to use the Stamp or Clone function from the MODE option.

To apply the Stamp function:

1. Set the size and shape with the SIZE and SHAPE options.
2. Set the transparency and feathering values you want.
3. Move the cursor to the selected area you want to copy.
4. Hold the [Shift] key and click. The stamp has picked up a copy of the

image selection.
5. Move to anywhere on the canvas you want to stamp and click.

To apply the Clone function:

1. Set the size and shape with the SIZE and SHAPE options.
2. To use the Clone function to trace one copy of the image, select

SINGLE in the SOURCE option. If you want to generate a tiled pattern
with the image, select TILE.

Set the transparency and feathering values you want.
4. Move the cursor to the starting point of the source image you want to

trace.
5. Hold the [Shift] key and click.
6. Move the cursor to the destination canvas where you want to start

tracing the image.
7. Click and drag the mouse to trace the image until the image appears

in the area you want to fill. 



Free-hand Rescale

This tool enables you to magnify or reduce the dimensions of a selected
area on the image. Before using this function, you must first select a
specific area for processing. To rescale a portion of the image:

1. Select the portion of image you want to rescale.
2. Click on the Free-hand Rescale icon. A rectangle with eight small

square nodes appears around the selected area.
3. Use the mouse to drag a node from any of the corners to magnify or

reduce the selected area. Or drag a node on any side of the rectangle
to rescale the image horizontally or vertically.
You can proportionally rescale the selected image by pressing and
holding the [Shift] key while dragging the nodes on the corners of the
rectangle. (See the picture on the next page).

 4. Release the mouse button.



Zoom In & Zoom Out

This tool enables you to obtain a magnified or a reduced view of an image.
The same effect can be achieved by using the Zoom In,  Zoom Out and
the Actual Size commands under the View menu.

To zoom in or out with the commands under View menu, follow these
steps:

1. Open the View menu and click on Zoom In or Zoom Out command.
A list of ratio options appears to the right of the command name.

2. Select the ratio by which you want the image to be zoomed in or out.
To restore the original view of the image, select the Actual Size
command.

To magnify or reduce the image with the Zoom tool, follow these steps:



1. Click on the Zoom tool.
2. Move the mouse cursor to the position you want to zoom in on.
3. Click the left mouse button to magnify the image; hold the [Ctrl] key

and click to reduce the image.
4. Click the right mouse button to view the image in its original size.

You can also magnify a specific portion of the image for more precise
editing. To do this, move your mouse cursor to the starting point of the
portion you want magnified, hold the [Shift] key, drag the mouse pointer
over the portion, and release the mouse button when you've selected the
desired portion.

A shortcut method to zoom in and out is to press the [+] (magnifying
by one level) or [-] (reducing by one level) key on the keyboard. This
method can be utilized at any time no matter which tool you're using.

Use the Fit in Window command under the View menu to display the
entire image in the image window frame. Use the Full Screen command
to display the image in a full screen size. Press [Esc] to return to the
editing screen.

You can also use the Add a View command under the View menu to look
at different size ratios of the image at the same time. 

Hue/Saturation Brush

This tool paints over your image using translucent shades of a color you
choose. The original shape of the image is not affected. This creates an
effect similar to tinted glass.

To paint with the Hue/Saturation Brush:

1. Click on the Hue/Saturation Brush icon.
2. Double click on the Hue/Saturation Brush tool to bring up the Tool

Control options.
3. Set the size and shape for the brush. If you need to change the

saturation, select Hue & Sat in Options.  If not, select Hue Only.



4. Move your mouse pointer to the starting point of painting.
5. Click and drag the mouse over your image.
6. Release the mouse button.

Brightness/Darkness Brush

The Brightness/Darkness Brush enables you to brighten or darken the
image along the cursor path.  To use this tool:

1. Click on the Brightness/Darkness Brush icon.
2. Double click on the Brightness/Darkness Brush tool to set the Tool

Control options.
3. Move the mouse cursor to the starting point of the area to be bright-

ened or darkened.
4. Hold and drag the left mouse button to brighten and the right button

to darken the image.
5. Release the mouse button.

Blur/Sharpen Brush

The Blur/Sharpen Brush enables you to create a blurred or sharp visual
effect on the image along the cursor path. To blur or sharpen the image:

1. Click on the Blur/Sharpen Brush icon.
2. Set the Tool Control options by double clicking the Blur/Sharpen

Brush tool.
3. Move the mouse pointer over the image.
4. Hold and drag the left mouse button to blur and the right button to

sharpen the image.
5. Release the mouse button.



Free-hand Rotate

This tool allows you to rotate a selected portion of image to any angle.
To rotate the image:

1. Select an image with one of the selectors.
2. Click on the Free-hand Rotate icon. Four square nodes appear on the

four corners of the rectangular area containing the selected portion.
3. Move the mouse pointer to any of the nodes.
4. Click and drag the node to rotate the image.

Hold the [Shift] key while dragging the node to rotate the image in 45
degree increments.
The status bar displays the rotating degree when you are dragging the
nodes.

5. Release the mouse button.

Curve

This tool allows you to draw a bézier curve by setting two nodes and four
control points. The nodes are located at both ends, and the control points
are extended from the nodes to help you adjust the height and slope of
the curve. The location of the nodes and control points can be adjusted
until you are satisfied with the shape and position of the curve. To draw
with the Curve Tool:

1. Click on the Curve tool.
2. Set the Tool Control options by double clicking on the Curve icon.
3. Place the mouse pointer where you want to start drawing your curve.
4. Click the left mouse button to set the beginning of the curve. Do not

release the mouse button.
5. Drag the mouse pointer in the direction you want the curve drawn. As

you drag, two control points appear and move in opposite directions
from the node. The distance between the control points and the node



determines the height or depth of the curve. The angle of the control
points determines the curve’s slope.

6. When the control points are in the desired position, release the mouse
button.

7. Repeat step 4 to set the other end of the first curve segment you want
to create. A second node appears that's connected to the first.

8. Drag to generate two control points for this node.

9. Release the mouse button. You may drag the nodes and control points
to adjust the shape of your curve segment.



If you didn't drag from the nodes to generate control points in previous
steps, you may hold the [Shift] key and drag from the nodes to create
control points anytime.

10. Click and drag the pointer outside the nodes and control points to form
another adjacent segment of curve linked with the first one. Repeat
steps 7 through 9 to complete all the segments in the curve you want
to create.

Before fixing the curve segments, you can click on any node to
activate the control points of the curve segment connected.
To remove the last node generated, hold the [Ctrl] key and click the
left mouse button.
If you want to create a closed area with the curve segments, hold the
[Shift] key and click the right mouse button to generate a new segment
connecting the last node to the first one.

11. When you are satisfied with the shape of your curve, click the right
mouse button to fix the curve.



Slant Tool

This tool distorts the image of a selected portion by extending it to a
parallelogram, trapezoid,  perspective view, or an irregular shape (free-
hand distortion). To use the Slant tool:

1. Select an image portion.
2. Click on the Slant icon. A rectangle with four small square nodes on

its corners appears around the selected area.
3. Set the Tool Control options by double clicking on the Slant icon.

Select the shape you want to change the image as parallelogram,
perspective, trapezoid or freehand distortion.

4. Drag the nodes on the rectangle to set the shape.
If you have selected to change the image as parallel, you may drag
the nodes horizontally or vertically. Once you have dragged the first
node horizontally, you can only drag all the nodes horizontally unless
you restart the tool (select another tool and then re-select this tool).

5. Release the mouse button.

Perspective
Parallelogram

Freehand
Distortion

Trapezoid



Smudge

The Smudge tool is used to randomly mix dots in an area. It works like
an artist who mixes colors with chalk or pastels. It can add a textured look
to a picture.

To use the Smudge tool:

1. Select the Smudge tool.
2. Set the Tool Control options by double clicking the Smudge icon.

The SPACING option determines the mixing level of smudging.
3. Move the mouse pointer over the image.
4. Click and drag the mouse to smudge the canvas.
5. Release the mouse button.



Image Hose

This tool sprays a series of pre-defined images along your cursor path.
This function can easily fill the canvas with a set of images in sequence
or randomly to achieve a special art design.

Five sets of images are provided with this tool. You can also define your
own sets of images to replace the default ones.

To apply the Image Hose:

1. Select the Image Hose tool.
2. Double click on the tool icon to open the Tool Control window.
3. Choose a set of pre-defined images from the Source pull-down list.

If you want to define your own set of images, read the instructions
below.

4. Select Linear, Random or Fixed in the Direction option to spray the
set of images in sequence, randomly or fixed on the first grid.

5. Move the pointer over the image.
6. Click and drag the mouse to paint the images on the canvas.



7. Release the mouse button.

To use your own set of images for Image Hose, you must first create the
set of images and then replace one of the default sources.

To define a set of images:

1. Create the set of images you want to use for Image Hose on a canvas
as you would create and edit any image.

2. Place the series of images in grids and note the grid size (width and
height) while arranging the images.

3. Use the Save As command in the File menu to save the canvas.
4. Pull down the Edit menu and click on Define Image Hose. A submenu

will appear listing five sets of image hose names.
5.  Click on the [Select Image File] button to add an image.  Choose your
image and click on the [OK] button.



6. Set the grid size according to the width and height you noted on step
2 in the Width and Height options. The grid lines in the preview will
window change according to your setting.

7. Enable or disable the Use Mask option.
When a mask is used, you should define a color and the color range
for producing the mask. The area of mask color in the image will
become transparent when you spray the images on the canvas.
If you want to use a mask, move the pointer into the preview window
and click on the color you want to become transparent. The selected
color is shown in the color box of Mask Color section. (See the
pictures on the next page).

8. Set the Valid Grid option to specify the image that will actually be
used for Image Hose (measured in grids).

9. Click on the [OK] button.



Texture Brush

This tool coats the canvas surface with a specified texture pattern. The
foreground color you select will be applied to the texture pattern.

Various texture pattern files are provided in the  subdirectory
of the Presto! ImageFolio program directory. Some of these textures
include stones, cloths, water waves, sands, etc. You can generate your
own texture pattern by creating the pattern, saving it as a BMP file, and
then placing it in the  subdirectory. To apply a texture with
Texture Brush:

1. Select the Texture Brush tool.
2. Double click on the tool icon to open the Tool Control options.
3. Set the size, shape, transparency and feathering options in the Tool

Control window.
4. Select the foreground color you want to use.
5. Move the pointer into the image and click the right mouse button. The

Load Texture dialog box will appear.



6. Choose a texture file from the  subdirectory of the Presto!
ImageFolio program directory.

7. Enable the Preview option to display the texture pattern in the preview
window.

8. When you have selected the texture pattern you need, click on the
[OK] button to close the dialog box.

9. Move the pointer over the image.
10. Click and drag the mouse to paint the texture on the canvas.
11. Release the mouse button.



Chinese Brush

This tool paints the image as if it were drawn with a Chinese brush.

To paint with Chinese Brush:

1. Select the Chinese Brush tool.
2. Double click on the tool icon to invoke the Tool Control options.
3. Set the pen size, shape, transparency and feathering options in the

Tool Control window.

You may set more feathering percentage to have the painted image look
more similar to what a Chinese brush produces.

4. Move the mouse pointer to where you want to start painting.
5. Click and drag the mouse to paint the image: left button to paint with

the foreground color and right button the background color.
The speed you move the mouse will affect the shape of painting.

6. Release the mouse button.



The Edit menu offers you the commands to copy, cut, and paste, in
addition to other image editing options.

Removing the Images

The Cut, Clear, and Crop commands become active only after you’ve
selected an area within the image. You can select an area by dragging
across the image with a selector tool. 

Cut

The Cut command removes a selected portion of an image and places it
on the clipboard. You can then use the Paste command to place the image
content last cut into another document. Only the most recently cut content
resides in the clipboard. To cut a portion of the image, follow these steps:

1. Select an area by dragging across the area with a selector from the
Toolbox.

2. Open the Edit menu, and click on the Cut command. The content of
the selected area is removed.

The keyboard shortcut to execute the Cut command is [Ctrl]+[X].



Clear

The Clear command deletes a selected portion of the image. This is
similar to the Cut command, but with a major difference: the content
deleted will not reside in the clipboard. In other words, you can’t bring
back the portion you deleted using the Clear command. To delete a
portion of the image, follow these steps:

1. Select an area by dragging across the area with a selector.
2. Open the Edit menu, and click on the Clear command. The deleted

portion is then filled with the background color.

You can also press the [Del] key on the keyboard to delete the selected
portion.

Crop

The Crop command allows you to cut out unwanted rectangular portions
of an image. If your selected area is not rectangular, the image canvas
will be cropped to the smallest rectangle in the selected area. To crop a
portion of image:

1. Select an area by dragging across the area with a selector.
2. Open the Edit menu, and click on the Crop command.

Joining Images

The pasting and stitching functions enable you to join portions of different
images into one image frame. Refer to the section Stitching Images in
Chapter 9 for explanations of the stitching function.



Paste

The Paste command pastes the content from the clipboard onto your
image. The command works only when there is already content in the
clipboard. To paste an image or text, follow these steps.

1. Open the Edit menu, and click on the Paste command.
A “phantom window” containing the content from the clipboard will
appear on your screen.

2. Move the pointer into the floating window. The pointer’s shape then
changes to an arrowhead-shaped cross.

3. Drag the phantom window to the location on your image where you
want to paste its content. 

4. Click the left mouse button outside of the phantom window to paste
the content.

The keyboard shortcut to execute the Paste command is [Ctrl]+[V].

Paste Into

This command is used when there is already a selection on the image and
you want to paste the content of the clipboard inside the selection outline
on the image. To paste into, follow these steps:

1. Open the Edit menu, and click on the Paste Into command.
A “phantom window” will appear.

2. Move the pointer into the floating window. The pointer’s shape then
changes to an arrowhead-shaped cross.

3. Drag the phantom window to the location inside the selected area
where you want to paste its content. 

4. Click the left mouse button outside of the phantom window to paste
the content.





Paste Behind

This command is used when you want to paste the clipboard contents into
the back of a selected portion of an image. To paste behind, follow these
steps:

1. Open the Edit menu, and click on the Paste Behind command.
A “phantom window” appears displaying the content of the clipboard.

2. Move the pointer into the floating window. The pointer’s shape then
changes to an arrowhead-shaped cross.

3. Drag the phantom window to the location on your image where you
want to paste its content.

4. Click the left mouse button outside of the phantom window to paste
the content.



Paste as New

This function enables you to paste the content of the clipboard as a new
document. The new canvas size depends on the size of the clipboard’s
content. To paste the content as a new document, open the Edit menu and
click on the Paste As New command. A new image window containing
the clipboard’s content will appear in the image editing area.

Composite Control

The Composite Control command enables you to set different Paste
options when pasting the clipboard’s content onto a canvas. To set the
Paste options:

1. Choose the Composite Control command from the Edit menu, or click
on its icon on the Icon Bar. The Composite Control dialog box will
appear.



2. Drag the little triangles or type in to enter a Transparency and
Feathering value.

3. The Fade option allows you to fade the colors of the image in a
selected frame along a specified direction. Click on the Fade check
box to enable the function.
Click on one of the eight small buttons below the Fade option to select
the fade direction.

4. Click on the [OK] button.

You can preview the result of your setting in the image window while
changing the values.

The following is an example after applying the Fade function.



Reproducing the Images

The Copy and Duplicate commands are used to reproduce or copy
images.

Copy

The Copy function enables you to make a copy of an image or text
selection and place it on the clipboard. The original image is unaffected
by the Copy command. You can then use the Paste options to move the
content last copied to another document. Only the last image copied
resides in the clipboard. To copy an image portion:

1. Select an area of the image by dragging across the area with a selector
from the Toolbox.

2. Open the Edit menu, and click on the Copy command. A copy of the
selected area then resides in the clipboard.

The keyboard shortcut for copying the image is [Ctrl]+[C].

Duplicate

The Duplicate function enables you to place the reproduction of an
existing image into a new canvas. When you execute the Duplicate
command, a new canvas appears on screen containing the same image as
that in the current active image editing window.

Moving a Portion of an Image to Other Canvases

Utilizing drag-and-drop, Presto! ImageFolio allows you to move a por-
tion of an image to another canvas without using menu commands.



1. Select an image area with a selector from the Toolbox.
2. Move the mouse pointer into the selected area.
3. Press and hold down the left mouse button.
4. Press the [Shift] key once and keep on holding down the mouse

button. The pointer’s shape changes to a hand scratching a piece of
paper.

5. Drag the mouse anywhere in the empty space outside of the image
where you will create a new canvas. Or drag the mouse to another
image canvas to place the selected image into it.

6. Release the mouse button.
7. Make changes to the selection if necessary.
8. Click the left mouse button outside of the selection or the right button

anywhere in the image window to fix the selection on the destination
canvas.

If there is already a selection on the destination canvas, you may press
and hold the [Ctrl] key during Step 4 above to paste the floating image
with the Paste Into or Paste Behind function. Move the floating image
inside the selection outline to paste it into the selected area; or outside
the selection outline to paste it behind the selected area.

Canceling the Last Operation

The Undo option cancels the last action the software performed. The last
action you performed is displayed at the right of the Undo command.
Click on this command or the Undo icon on the icon bar to undo the action.

This function is disabled by default, but you can enable it by using the
Preferences command under the File menu. With Undo turned off, the
program doesn’t have to keep track of your actions, and devotes more
memory to other features. General operation speed is thus faster when
Undo  is disabled.

If you aren’t satisfied with the modifications you’ve made to an image,
you can recover the original image last saved by using the Revert



command under the File menu. The software will quickly reload the
original image.

Mask and Floating Selection

The outlines made by the selectors on an image compose an editing mask.
This mask can be applied to other images. In other words, you can save
and load the shape of a specific outline (the mask) for use with other
images.

The Floating feature allows you to work on a selected portion of an  image
without affecting the original image. You can move and edit the selected
portion, then paste it back onto the original image.

To float (or move) a selected portion of the image:

1. Move the mouse pointer inside the selected area. The cursor changes
to a four-headed arrow.

2. Click and drag the selection to the desired location.
3. Release the mouse button.

After you have made all necessary changes to the selected portion, click
the left mouse button outside the selection to fix the floating image onto
the canvas, or click on the right button anywhere in the image window.

The following subsections describe the workings and functions of float-
ing operations.

Load Mask

You can load a pre-defined mask for the usage of any image. To load a
mask:

1. Open the Edit menu and select the Mask Load Mask command. The
Load Mask dialog box will appear.



2. Select the mask you want to load and click on the [OK] button. The
selected mask will be loaded in at the same location on the current
image as the location it was originally saved at.

Save Mask

A selection frame can be saved with the MSK file extension for later use.
To save a mask:

1. Open the Edit menu and select the Mask Save Mask command. The
Save Mask dialog box will appear.

2. Select the directory you want the mask to be saved in and enter a
filename for the mask. 

3. Click on the [OK] button.



Invert Selection

You can invert any selection, which means to have a selected area outside
of the selection frame and edit that area outside of the frame. To invert
the selection:

1. Use a selector to select a portion of the image.
2. Open the Edit menu and select the Mask Invert Selection command,

or click on the Invert Selection icon on the icon bar.

Click again to reverse the selection back to the enclosed area inside the
outline(s).

Select All

The Select All command enables you to select an entire image. To do so,
use the Select All menu command or click on its icon on the icon bar.

Abandoning Selection

Before making changes to a selected portion, you can abandon the
selection by using the Abandon Selection command. After having made
changes to a selected portion, you can also use the Abandon Selection
command to fix the floating image on canvas.

To abandon the selection you can also simply click on the Abandon
Selection icon on the icon bar, click the left mouse button outside of the
selection, or click the right button any where in the image editing window.

Discarding Floating

This is used to discard changes you have made to a selected portion. Use
the Discard Floating command to remove the floating selection.



Copy Floating

Copy Floating enables you to keep the floating image after you’ve fixed
the selection on the canvas.

Make Floating

Make Floating makes your selection a floating image for further editing.

Painting According to the Selection Frame

Once you’ve selected an image portion, you can add colors to it by using
the Fill, Stroke, and Pattern commands.

Filling a Color into the Selection

The Fill command allows you to fill the entire area inside the selection
frame with the foreground color. To fill a selected area with the fore-
ground color:

1. Select an image portion.
2. Pick a foreground color from the color palette.
3. Open the Edit menu and click on the Fill command, or click on its

icon in the icon bar.

Adding Outlines by Tracing the Selection Frame

The Stroke function enables you to add outlines around a selection.
Presto! ImageFolio will draw outlines along the selection frame using the
foreground color. You can select to draw outlines outside, inside, or over
the selection frame. To produce this effect:

1. Select an image portion.



2. Pick a foreground color from the color palette.
3. Open the Edit menu and select the Stroke command. A dialog box

will appear

4. Set the thickness of the outlines to be added with the Size option. The
effective values are from 1 to 20 pixels.

5. Set the Transparency and Feathering options by dragging the little
triangles or entering the percentage directly.

6. Select the position of drawing the outlines inside the selection frame
(Inside), outside the selection frame (Outside) or over the selection
frame (Center).

7. Click on the [OK] button.

Fill In Pattern

The Pattern command allows you to fill the entire canvas or inside the
selection frame with tiled images.



The pattern used to fill the area can be defined by saving a selected portion
of an image (or the content on the clipboard) as a pattern file with the
PAT file extension.

To apply this feature:

1. If you want to use an image selection as your pattern source, select an
image portion with one of the selectors from the Toolbox. 

2. Select Pattern from the Edit menu. Choose Save as Pattern from
Current Selection or Save as Pattern from Clipboard from the pop-up
submenu. When the Save as Pattern dialog box appears, save the
image with PAT file extension.

3. Make the canvas you want to fill the pattern active. If you want the
pattern filled in a specific area (not the entire canvas), make the
selection now.

4. Select Fill In Pattern from the Pattern submenu. A dialog box will
appear.



5. In the Pattern Source section, click on the [Clipboard] button to load
the image on the clipboard or the [File] button to select a pre-defined
pattern file. The image appears as tiles in the Preview window.

6. Adjust the vertical and horizontal shifting length among the rows of
tiled images with the Vertical Shift, Horizontal Shift and Percent
options. 

7. Click on the [Apply] button to apply this function.

Calculate Image

By calculating the color values of the pixels in  two images, you can create
different special effects while combining images. This function can be
used to color gray-scale images and manipulate or compare two images.
To apply this function:

1. Open the image(s) you want to calculate.
2. Select Calculate from the Edit menu. The Calculate Image dialog box

will appear.
3. Under Source 1, select the first image you want to compute by its

filename, and the color channel in the image to be calculated.
4. Under Source 2, select the second image you want to compute and

the color channel. Source 2 can be the same as Source 1 or it can be
a different image.
The images of Source 1 and Source 2 can be different sizes. If they
are different sizes, the software will only compute the pixel values in
the overlapping area from the upper left corner of the two images.
Click on any sample image to display its file information.

5. In the Operator section, choose a calculating method from the pull-
down list. The Hint section at the lower part of the dialog box displays
the computing formula of the selected computing method.



Add
Use this method to add the individual pixel values in two images. You
can produce an average of two images or convert a gray-scale image
to a tinted color image.
Subtract
This method subtracts the pixel values in the Source 2 image from
those in the Source 1 image.
Multiply
Multiplying image pixel values with themselves is a useful method of
increasing depth and contrast in a light image. If you multiply an
image by itself, all pixel values (except 255) get darker. 
Difference
This method is used to compare two images. When two images are
the same, the result will be a pure black image. If there is any
difference it will be shown.



Blend
This method blends two images together. It adds a percentage of the
Source 1 individual pixel values to a percentage of the Source 2
values. That is, the “transparency” you set for one image determines
that of the other.
Composite
This method applies gray scales to the source images by using a mask.
This is useful when you want to make different levels of enhancement
to highlight or shadow specific areas on the image.

Lighter
This method combines the source images into a new lighter image. It
picks the lighter values after comparing the pixel values of the
images.
Darker
This method combines the source images into a new darker image. It
picks the darker values after comparing the pixel values of the images.

6. According to the formula shown in the Hint section, set the factor,
base and percentage for computing.
If you have selected Composite computing method, you should
choose an image for making a mask to apply gray scales to the source
images. The mask can be defined with single color channel or all
colors.

7. Under Destination, select a file for the calculation result to be placed.
It can be an existing file or a new one.

8. Click on the [OK] button to apply the effect.

The pictures on the next few pages are examples of calculating methods.







The commands under the Transform menu are used to flip, rotate, or
convert images. Generally speaking, these commands transform the
position, size, or colors of an image without changing its shape and
pattern.

Inverting Image Color/Brightness

The Invert command reverses the brightness and color of an image as
illustrated below. Click on the Invert command to invert. Click again to
get back the original image.



Flipping Images

The Mirror command flips the image vertically, horizontally, or diago-
nally as illustrated below.



Rotating Images

The Rotate Left command rotates the image by 90 degree counter-clock-
wise.

The Rotate Right command rotates the image by 90 degree clockwise.



The Arbitrarily Rotate command allows you to rotate at any angle the
selected portion of an image or the entire image. To execute this:

1. Click on the Arbitrarily Rotate command name.  A dialog box will
appear.

2. Click on the clockwise (CW) or counter-clockwise (CCW) option for
the rotating direction.

3. Enter the rotation angle.
4. Click on the [OK] button to start rotating the image.

Rescaling Images

The Rescale function allows you to change the size, resolution, and
scaling factors for the entire image. You can easily enlarge or shrink an
image.

Please refer back to the section entitled Rescale the Image for Printing
in Chapter 4 for details.



Converting Images

The Change Image function allows you to convert the image canvas
format. To convert an image:

1. Choose the Change Image command from the Transform menu, or
click on its icon in the icon bar. The Change Image Type dialog box
will appear.

2. Select a Target Type option which correspond to the image conversion
you want. The options are:

This option converts the active image to two color,
black and white.

This option converts gray, 256 color, or true color
images to 16 colors.

This option converts the active image to 16 gray
shades, from black (zero) to white (15). The gray
scale image type gives the best representations of
black-and-white images.



This option converts gray and 256 color images to
RGB true color image (16.7 million colors). This
data type is currently the best image data type for
editing color images because it retains the maxi-
mum amount of information about the image.

This option converts gray and true color images to
256 colors.

This option converts the active image to 256 gray
shades, from black (zero) to white (255), which
smoothes tonal changes by using intermediate gray
tones. Again, the gray scale image type gives the
best representations of black-and-white images.

Dimmed options are not appIicable to the active image.

3. Click on the [Set Convert] button to specify a converting method. The
Set Convert dialog box will appear.



When transferring an image to screen, this option
converts the picture’s original colors to the closest
matching colors within the system’s indexed color
palette.

This option calculates the color pixel values and
determines the most suitable colors for an image.

This option averages the bright and dark color
pixels on the image.

This option is for palette editing.

This option converts the image with different pat-
terns and sizes to generate special effects. Both the
Dithering Pattern and Pattern Size options allow
you to execute conversions with different patterns
and sizes. The following examples illustrate differ-
ent dithering patterns.

4. Click on the [OK] button to complete the conversion.





Expanding the Canvas

The Expand Image function in the Transform menu lets you increase the
size of canvas without influencing the image size. You can set the image
position on the canvas after the expansion.

To expand the canvas:

1. Select Expand Image from the Transform menu. A dialog box will
appear.

2. The Source Image field displays the current image size. Change the
size with the Target Image option.

3. In the Source Image Offset section, use the values of X and Y axes or
the nine direction buttons to set the position of the original image after
expanding the canvas.
You can also move the mouse pointer into the preview window at left
and drag the black rectangle to set the position of the original image.

4. Click the [OK] button to expand the canvas.



The options in the Process menu are designed to fine tune images or
enhance them through special effects. Scanned or captured images usu-
ally need post-processing to make them look more natural.

The options in the Process menu and the image types that they can be
applied to are listed in the table below.



Adjusting Brightness/Contrast

The Brightness/Contrast command is used to change the brightness and
contrast of the image pixels. To alter the brightness/contrast level of the
image, open the Set Brightness and Contrast dialog box:

1. Open the Process menu and click on the Brightness/Contrast com-
mand. The Set Brightness and Contrast dialog box will appear.

2. Select a Channel option for processing: either Red, Green, Blue, or
All.

3. Enter a value in the Brightness and Contrast text boxes, or drag the
scroll boxes to set a value.

4. The Sample image changes accordingly as you drag the scroll boxes
or enter the values. You can compare the Sample image to the
Original to clearly identify your adjustment.

5. Click on the [OK] button to make the change.

You can restore the original settings by clicking on the Original image.



Adjusting Hue/Saturation

The Hue/Saturation command is used to change the hue and saturation
of the image’s colors. To alter the Hue/Saturation of the image, follow
these steps:

1. Open the Process menu and click on the Hue/Saturation command.
The Set Hue and Saturation dialog box will appear.

2. Enter a value in the Hue and Saturation text boxes, or drag the scroll
boxes to set the values.

3. The Sample image changes accordingly as you drag the scroll boxes
or enter the values. You can compare the Sample image to the Original
to clearly identify your adjustment.

4. Click on the [OK] button to make the change.

You can restore the original settings by clicking on the Original image.

Adjusting Equalization

The Equalize command is used to sharpen dull images or tone down
overly sharp images by redistributing the gray shades in them. 



To adjust the equalization, follow these steps:

1. Choose the Equalize command from the Process menu. The Equali-
zation dialog box will appear.

2. Select a Channel option for processing. Choose either Red, Green,
Blue, or All.

3. Drag the triangle sliders to select the input and output ranges, or enter
the value in the text box.
To increase the contrast and bring out the details of the image, you
can decrease the input range. On the other hand, you can reduce the
output range to decrease contrast and lighten the shadowed areas, or
darken the highlighted areas. 
Drag the left triangle to the right for decreasing contrast and lighten-
ing the shadowed areas, or drag the right one to the left for decreasing
contrast and darkening the highlighted areas.

4. The Sample image changes accordingly as you drag the scroll boxes
or enter the values. You can compare the Sample image to the
Original to clearly identify your adjustment.

5. Click on the [OK] button to make the change.

You can restore the original settings by clicking on the Original image.



Adjusting Color/Gray Map

The Color/Gray Map command is used to alter the brightness value of
each pixel in the image by directly changing the mapping curve of
gray/color values.

The horizontal axis represents the input’s brightness level and the vertical
axis represents the output’s brightness level. “0" represents pure black,
and ”255" pure white. To adjust the mapping:

1. Choose the Color/Gray Map command from the Process menu. The
Color/Gray Map dialog box will appear.

2. Select a Channel option for processing, either Red, Green, Blue, or
All.

3. Choose a way to adjust the map from the Method options.
If you choose the Gamma option, you can enter a gamma value in the
Gamma text box. Enter a higher value to lighten the midtone area or
enter a lower value to darken the midtone area. The shape of the
mapping curve will change according to your settings.
If you choose the Linear option, the default gamma value is 1.0. The
image will retain its original outlook.



If you choose the User Defined option, point to anywhere on the mapping
curve and drag it to form the shape corresponding to the image outlook you
want. Changing the slope of the line adjusts the contrast; changing the level
of the line adjusts the brightness.

4. The Sample image changes accordingly as you drag the scroll boxes or enter
the values. You can compare the Sample image to the Original to clearly
identify your adjustment.

5. Click on the [OK] button to start the process.tart the process.

Variations

The Variations dialog box provides you with a preview mode to adjust
dark, midtone and light areas of an image in hue, saturation, or bright-
ness/contrast. It gives you instant comparison between the original im-
ages and the result of changes you may make on it.

To use Variations:

1. Select the Variations command from the Process menu. The Vari-
arions dialog box will appear.
In the left portion of the Variations window, you have nine image
previews showing different effects of hue and brightness adjust-
ments. Among them, Sample represents your current selection taken
from the eight surrounding possibilities.
The six previews at the top and bottom of the Sample reflect the hue
adjustments to the Sample image; the two previews at the left and
right of the Sample show brightness adjustments.
On the right hand portion of the dialog box are two images: the left
hand one is your current selection. The right hand side is a copy of
your original image. 

2. Drag the triangular slider under the Finer and Coarser line to define
the adjustment level as a slight or more pronounced adjustment.Your
setting will be immediately reflected on the left side previews.

3. Click on the preview which best satisfies your needs. The selected
preview will move into the Sample position, and the surrounding
previews will change according to the new Sample.



You may recall the Original as the Sample image by clicking on the
Original image.

4. If you want to change only the light, midtone, or dark area in the
image, click to select the Highlights, Midtones, or Shadows option
respectively.

5. If you want to change  the saturation of the image, click on the
Saturation option. The left half of the dialog box then displays the
Sample as well as the effects of lower (less) and higher (more)
saturation (see Figure 8-6). 

6. If you want to change the image’s brightness and contrast, click on
the Bright/Contrast option (see Figure 8-7). The three top image
previews reflect the effects of enhancing contrast, and the three
bottom ones the effects of reducing contrast. The three left image
previews reflect the effects of decreasing brightness, and the three
right ones the effects of increasing brightness. 

7. After you obtain a satisfying Sample, click on the [OK] button to start
the process of adjustment, or click on [Cancel] to abandon the process.





Smoothing Images

The Smooth command allows you to soften an image at three levels:
Smooth, Smooth More, and Smooth Edge. Choose Smooth to slightly
soften the image. If you want to make the image look even softer, choose
Smooth More. The Smooth Edge option only softens the edges of objects
in the image.

Sharpening Images

In order to improve its clarity, the Sharpen command allows you sharpen
an image at three levels: Sharpen, Sharpen More, Sharpen Edge. The
Sharpen option makes the image a little clearer. The Sharpen More option
sharpens the image even further. The Sharpen Edge option only sharpens
the edges of objects in the image.

Edge Editing

Two commands are provided to enhance the edges of an image.

Find Edge

The Find Edge command is used to automatically find and display the
edges of the objects on the image canvas with white or gray shades on a
gray-scaled image, and with the original colors of the areas at the side of
the edges of the image on an RGB color image.



Trace Contour

The Trace Contour filter converts images into a bi-level format in which
image outlines are clearly marked. For a gray-scaled image, the outlines
contain only black and white pixels; and for an RGB color image, they
contain up to eight colors (black, white, red, green, blue, cyan, magenta,
and yellow).

To utilize the function:

1. Open the Process menu and select Trace Contour. The following
dialog box will appear.

2. In the Level option drag the triangle slider to set the difference
between the values of any two neighboring colors in the image. While
tracing image outlines, only when the difference of  two neighboring
colors reaches the specified level can the outline between them be
traced.

3. Selecting the Upper or Lower option decides the color and position
of the image outline between neighboring colors. If you check the
Upper option, the outlines will be traced with the colors of higher
values between neighboring colors; if you check the Lower option
however, the outlines will be traced with the colors of lower values.

4. Click on the [OK] button.



Diffuse

The Diffuse command blurs the image by diffusing its colors. The blurred
image looks like an image seen through a water surface.

Despeckle

The Despeckle command automatically clears the small speckles on the
image.  



Emboss

The Emboss filter makes the image stand out from the paper surface or
stand in relief against its background. The emboss process coats the image
with mostly foreground color on the surface of objects, and with midtone
colors from the originals for object outlines. To utilize this effect:

1. Select the Emboss command from the Process menu. The following
dialog box will appear.

2. In the Direction option, click on one of the eight arrow buttons
matching the emboss direction you want.

3. In the Depth section, select the depth as High, Middle or Low.
4. Click on the [OK] button.

Mosaic

The Mosaic command is used to display an image as a series of mosaic
tiles. The colors of the tiles are averaged with the original image colors.
To achieve this effect:



1. Open the Process menu and click on the Mosaic command. A list of
available tile sizes (in pixels) pops up to the right of the command
name with check mark to the left of the current size.

2. Click on the tile size you want.



Adding Noise

The commands Add Noise, Color Noise and Splatter will randomly add
generated color pixels to your images.

The Add Noise command can generate color pixels in different levels of
brightness of the original colors in the image.

To generate this effect:

1. Select the Add Noise command from the Process menu. The Add
Noise dialog box will appear.

2. Drag the triangle slider in the Frequency option to set the density for
generating color pixels on the image. 

3. In the Intensity option, set the level of brightness for the generated
color pixels.
If you set the intensity between 0 and 50, the color pixels generated
will be lighter than the original colors. If you set  the intensity
between 0 and -50, the color pixels will be darker.

4. Click on the [OK] button.



Color Noise

The Color Noise command generates color pixels by using the RGB
values of the original colors in the image, as well as colors you specify.
To generate this effect:

1. Select the Color Noise command from the Process menu. The Color
Noise dialog box will appear.

2. Drag the small triangle in the Frequency option to set the density for
generating color pixels on the image. 

3. In the Intensity option set the brightness level of the generated color
pixels.

4. Click on the [OK] button.

Splatter

The Splatter command generates black pixels on the image. To utilize
this function:

1. Select the Splatter command from the Process menu. The Splatter
dialog box will appear.



2. Drag the triangle slider in the Percentage option to set the density.
3. Click on the [OK] button.

Solarize

Applying the Solarize function makes an image look like an over exposed
photograph.  Click on the Solarize command name to start the process.

Tiles

This command can cut an image into small square pieces and rearrange
them to form the image. To utilize this function:

1. Open the Process menu and click on Tiles. The following dialog box
will appear.



2. In the Size of Tiles option set the dimension of the tiles.
3. Set the distance between the pieces in the Maximum Offset option.
4. Select the background under the image pieces as Foreground Color,

Background Color, Unaltered Image (the original image) or Inverted
Image.

5. Click on the [OK] button.



Texturize

This command coats the canvas surface with a specified texture pattern.
The foreground color you select will be applied to the texture pattern.

Various texture pattern files are provided in the  subdirectory
of the Presto! ImageFolio  program directory. You can generate your own
texture pattern by creating the pattern, saving it as a BMP file, and then
placing it in the  subdirectory. To apply a texture to the
image:



1. Make a selection in the image, or the texture will be applied to the
entire canvas.

2. Select the foreground color you want to use with the texture pattern.
3. Select the Texturize command from the Process menu. The Load

Texture dialog box will appear.
4. Choose a texture file from the  subdirectory of the Presto!

ImageFolio program directory.
5. Enable the Preview option to display the texture pattern in the preview

window.
6. When you’ve selected the texture pattern you need, click on the [OK]

button to apply the texture.



Producing Vague Images

Average, Maximum, and Minimum commands can produce vague images
by calculating the values of each pixel with its surrounding pixels.

Average

The Average command averages the values of each pixel and its surround-
ing pixels.

To apply this function:

1. Click on Average in the Process menu. A submenu appears to the
right of the command name.

2. Select the pixel block size for calculating the new color values from
the submenu. 

Maximum

The Maximum command enlarges the bright area in the image. To apply
this effect:

1. Click on Maximum in the Process menu. A submenu will appear to
the right of the command name.

2. Select the pixel block size from the submenu. 

Minimum

The Minimum command enlarges the dark area in the image. To apply
this effect:

1. Click on Minimum in the Process menu. A submenu will appear to
the right of the command name.

2. Select the pixel block size from the submenu.



Fragment

When executing the Fragment function, Presto! ImageFolio will move
the image in up, down, left and right directions to generate four temporary
images, and then overlap the four images with a degree of transparency.
To apply this effect:

1. Open the Process menu and select Fragment. A submenu will appear
to the right of the command name.



2. Select the distance for moving the image in four directions. The
higher the value, the more obvious the effect.

User-defined Filter

The function of filters is to enhance images or generate special effects.
Most commands in the Process menu like Smooth, Sharpen, Find Edge,
Emboss, and Mosaic were designed with a variety of settings based on
modern filter theory. Beside the filters provided in the software, you can
create numerous additional special effects by setting user-defined filters.
You may also save them as files and recall them.

To define a filter:

1. Select the User-defined Filter command from the Process menu. A
dialog box will appear.

2. Set the filter matrix as 3x3 or 5x5 in the Filter Size option.
3. Choose a method for entering values to the filter matrix in the

Symmetry field.
The values will not be automatically entered when the No option is
selected.
When the Horizontal option is enabled, the value you enter in the
matrix will also be added to its horizontally opposite positions. For
example, if you enter the value “1" at the upper left corner of the



matrix, the same value will also appear at the upper right corner of
the matrix.
When the Vertical option is enabled, the value you enter in the matrix
will also be added into its vertically opposite positions in the matrix.
For example, if you enter the value “3" at the upper left corner of the
matrix, the same value will also appear at the lower left corner of the
matrix.
When the 4-Way option is enabled, the value you enter in the matrix
will be added into its vertically, horizontally, and diagonally opposite
positions in the matrix. For instance, if you enter the value “5" at the
upper left corner of the matrix, the same value will also appear at the
lower left, upper right, and lower right corners of the matrix.

4. In the User-defined Filter window, enter the values composing the
filter matrix. The process of selection of matrix values to produce
special effects on the image is a very technical matter. If you are not
familiar with it, you should refer to books about image processing
filter theory for further information.

All the values entered in this dialog box should be in the range from
-999 to 999.

5. Click on the Invert check box if you want to invert the new image
after the matrix calculation. For example, if the pixel value after



matrix calculation is 50, the value will be changed to 205 after you
enable the Invert option.

6. Click on the Use Threshold check box if you want to convert the new
pixel values to binary values; the values exceeding the Threshold
value will be converted to 255 (white) and those smaller than the
Threshold value will be converted to 0 (black).

7. If you have enabled the Use Threshold option, enter a Threshold value
in the Threshold text box.

8. If you enter a value in the Factor option, the pixel values (“X” in the
above example) will be divided by the factor value after the matrix
calculation.

9. The Base value, if you’ve entered one, will be added to the result after
the new pixel values are divided by the factor.

10. Click on the Rotation check box if you want to rotate the matrix by
90 degrees. The new pixel values will be the average of the results of
the original and rotated matrix calculations.

11. If you want to save the filter setting, click on the [Save] button. A
dialog box will appear for you to enter the filename for your filter.
The filenames for filters use the extension .

12. Click on the [Load] button to recall a previously saved filter file.
13. After returning to the User-defined Filter dialog box, click on [OK]

to start image processing with the filter.

Plug-in Interface

Presto! ImageFolio supplies an interface for utilizing third-party filters
and other plug-ins. If you want to use plug-ins, you should set the path
of the plug-in programs in the Adobe Plug-in Path option of Preferences
dialog box (all the plug-in programs should be kept in one directory).
Presto! ImageFolio will search for all the plug-ins and add them into the
Process menu the next time you restart it.



The Stitch command (under the Edit menu) can stitch or merge two or
more images into one. With the Auto Stitch and Intelligent Stitch func-
tions, you can easily join separated parts of images. Manual Stitch,
however, is mostly applied when stitching images with pronounced
differences. To stitch images:

1. Choose the Stitch command under the Edit menu. or click on its icon
on the icon bar. The Stitch Images dialog box will appear.



2. Select the file you want to stitch  from in the Matched Picture section.

3. Select the file you want to stitch to in the Matching Picture section. 
4. Select a Stitch Control option, either top, right, bottom, or left

depending on where you want to put the Matching picture.

The stitching picture will be converted to reflect the image type of
picture it is stitching on.

5. Select a way to stitch the image by clicking on one of the Stitching
buttons.

Manual Stitch

You have to specify the overlapping reference points precisely on both
images. To stitch images manually:

1. Click on the [Manual Stitch] button. The image editing screen appears
with both images. You will see a stitching frame in the stitching
image.

2. Move the stitching frame to the reference portion to be overlapped
and click. The stitching frame with the stitching reference portion will
move to the receiving image.

3. Move the stitching frame to the overlapping reference portion in the
receiving image and click. The images are stitched.

If the edges of two images of different lengths or size are to be linked
in the matching, you can only stitch the images manually.

Intelligent Stitch

To use Intelligent Stitching, the receiving image has to be a 24-bit true
color or a 256 gray scale image.



You have to specify the overlapping reference portions but it does not
have to be as precise as is needed for Manual Stitching. The difference
between manual and intelligent stitch is that intelligent stitch can adjust
the sizes, and contrast of the edges of stitched images. Follow the
instructions below to execute intelligent stitch:

1. Click on  the  [Intelligent  Stitch]  button.  The  image  editing  screen
will appear with both images. You’ll see a stitching frame in the
stitching image.

2. Move the stitching frame to the reference portion to be overlapped
and click. The stitching frame with the stitching reference portion will
move to the receiving image.



3. Move the stitching frame to the overlapping reference portion in the
receiving image and click. The images are stitched.

The overlapping reference range
has a tolerance of 10 pixels.



If you select the Top or Bottom option from the Stitch Control, the width
of the two images should be the same or of no more than a 3% difference.
If you select the Left or Right option, the height of the two images should
be the same or of no more than a 3% difference.

Auto Stitch

For Auto Stitch, the receiving picture has to be a 24-bit true color or
a 256 gray scale image.

You don't  need to specify any reference point for stitching. Presto!
ImageFolio will automatically calculate and stitch the images.

Adjust the Overlap Range in Auto slider to set the overlapping width of
the images. An overlapping frame will appear in the Matching Picture
section of the dialog box. The frame will move as you adjust the slider.



If you select the Top or Bottom option from the Stitch Control, the width
of the two images should be the same or of no more than a 3% difference.
If you select the Left or Right option, the height of the two images should
be the same or of no more than a ±3% difference.

Move this frame to the stitching edge
according to the Matched Picture.



The following glossary explains the terms used throughout the manual.











This appendix lists the key combinations available in the software.

Keyboard Usage for Menu Commands

Many commands on the menus have keyboard equivalents.

[Alt] Combined with the underlined letter of an item on
the menu bar, pulls down and open the menu. (To
invoke a menu command or a dialog box action,
press the appropriate underlined letter).

[Ctrl]+[Z] Undo

[Ctrl]+[S] Save

[Ctrl]+[R] Revert

[Ctrl]+[X] Cut

[Ctrl]+[C] Copy

[Ctrl]+[V] Paste

[Del] Clear



[F1] Help Index

[Shift]+[F1] Keyboard Help

[F3] Toggle Toolbox display

[F4] Toggle Tool Control display

[F5] Toggle Palette Control display

[F6] Toggle Rulers display

[F7] toggle Icon Bar display

[F8] Toggle Status Bar display

[Shift]+[F5] Cascade

[Shift]+[F4] Tile

[Enter] Execute the current command

[Esc] Cancels the current command

[+] Zoom in

[–] Zoom out



Keyboard Usage for Palette Control

The table below lists the keyboard and mouse operations for editing the
color palette.

Click Mouse Left Button Pick a foreground or background color

[Shift]+Click Left Button Select or deselect colors

[Shift]+Click Right Button Deselect all the currently selected color

[Shift]+Drag through a
block of colors

Select a block of colors

[D] Delete the selected colors

[Ctrl]+Click Left Button Insert the selected colors starting from
the color grid you are now on

[Alt]+Click Left Button Replace the colors of the color grid you
are on with the selected ones



Mouse Operation and Keyboard Usage for Tools

The keyboard usage for Tools is combined with the mouse actions to edit
the image.

Different functions are performed for different tools while holding the
[Shift] or [Ctrl] key and clicking/dragging the mouse:

Selectors as Rec-
tangle Selector,
Ellipse Selector,
Magic Wand, etc.

[Shift]+drag the left 
button
[Ctrl]+drag the left 
button

Increase the selected area

Decrease the selected area

Rectangle Selec-
tor

[Shift] twice + drag the
left button

Select a square area

Ellipse Selector [Shift] twice + drag the
left button

Select a circular area

Free-hand Selec-
tor

Double click the mouse
left button

Completing the selection

Selector Brush Drag the left button
Drag the right button

Add Selection
Exclude Selection

When there is a
selection on the
image

[Ctrl]+click right button Invoke the Mask submenu

Line [Shift]+drag the left 
button
[Ctrl]+drag the left 
button

Draw a line in an angle of 45 degree
increments
Draw adjacent lines

Rectangle [Shift]+drag the left 
button

Draw a square

Ellipse [Shift]+drag the left
button

Draw a circle

Gradation Click the right button Select multiple colors



Paintbrush, 
Chinese Brush,
Airbrush

Click or drag the left
button
Click or drag the right
button

Paint with foreground color

Paint with background color

Stamp [Shift]+click the left
button

Pick the image for stamping or set
the starting point for cloning

Zoom [Shift]+drag the left
button
[Ctrl]+click the left
button
Click the right button
[Esc]

Fit a part of the image in image 
window
Zoom out

Actual size display
Return to the editing area from Full
Screen display

Brightness/
Contrast Brush

Click or drag the left
button
Click or drag the right
button

Brighten the image

Darken the image

Blue/Sharpen
Brush

Click or drag the left
button
Click or drag the right
button

Blue the image

Sharpen the image

Free-hand Rotate [Shift]+drag the left 
button

Rotate in 45 degree increments

Curve [Shift]+drag on the node
[Shift]+click the right
button
[Ctrl]+click the left 
button
Click the right button

Generate control points
Close the curve segments

Remove the last generated node

Complete the curve segments

Image Hose [Shift]+click the left
button

Avoid overlapping sprayed images

Texture Brush Click the right button Select a texture pattern



This appendix lists the functions of all the icons appearing in the software.

Icons on the Icon Bar

New

Open

Save As

Print

Document Info

System Info

Image Manager

Abandon Selection

Stitch

Undo

Invert Selection

Select All

Fill

Composite Control

Change Image



Icons in the Toolbox

Rectangle Selector

Ellipse Selector

Free-hand Selector

Selector Brush

Move Selection

Magic Wand

Paintbrush

Text

Pan

Gradation

Stamp

Eraser

Image Hose

Slant

Curve

Free-hand Rescale

Free-hand Rotate

Line

Rectangle

Ellipse

Airbrush

Zoom

Eyedropper

Paint Bucket

Hue/Saturation Brush

Brightness/Darkness Brush

Blur/Sharpen Brush

Texture Brush

Chinese Brush

Smudge



Icons on the Status Bar

Toolbox Button

Tool Control 
Button

Icon Bar Button

Palette Control Button

Icons in the Palette Control

Spectrum On/Off

Primary Palette
On/Off

Scratch Pad On/Off

Save as File

Load from File

Append from File

Load from Primary
Palette

Save to Primary Palette

Get Colors Used Most from 
Canvas

Create Gradation of Colors

Sort by Hue

Sort by Tint



Icons in Image Manager Dialog Box

Information

Refresh

Sort by Filenames

Sort by Date

Sort by File Size

Copy

Delete

Rename

File List
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